一.扩扑图

AC3222802.png

二.基本配置

SW1

vlan batch 10 20
interface GigabitEthernet0/0/24
 port link-type trunk
 port trunk pvid vlan 10
 port trunk allow-pass vlan 10 20

interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

SW2

vlan batch 10 20

interface GigabitEthernet0/0/24
 port link-type trunk
 port trunk pvid vlan 10
 port trunk allow-pass vlan 10 20

interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

SW3

vlan batch 10 20 30

interface GigabitEthernet0/0/24
 port link-type trunk
 port trunk pvid vlan 10
 port trunk allow-pass vlan 10 30
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

AP管理VLAN 10

STA业务VLAN 20 30

AC

vlan batch 10 20 30

dhcp enable

三.DHCP服务器

AC作为DHCP服务器为AP地址

ip pool vlan20

 gateway-list 192.168.20.254 

 network 192.168.20.0 mask 255.255.255.0 

 dns-list 8.8.8.8
ip pool vlan30

 gateway-list 192.168.30.254 

 network 192.168.30.0 mask 255.255.255.0 

 dns-list 8.8.8.8 
interface Vlanif 10
ip address 192.168.10.254 24
dhcp select interface 

interface Vlanif 20
ip address 192.168.20.254 255.255.255.0
dhcp select global

interface Vlanif30
ip address 192.168.30.254 255.255.255.0
dhcp select global

interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 20 30

四.AC出接口

AC

ip route-static 0.0.0.0 0.0.0.0 192.168.10.1

LSW3

interface Vlanif10

 ip address 192.168.10.1 255.255.255.0

五.建立CAPWAP隧道

capwap source interface Vlanif 10

wlan

六.AP组

AC

ap-group name apg

q

regulatory-domain-profile name default

country-code cn

SSID模板 名称:net

SSID名称:net

ssid-profile name net

ssid net

安全模板 snet

安全策略:WPA-WPA2+PSK+AES

密码:a1234567

security-profile name snet

security wpa-wpa2 psk pass-phrase a1234567 aes

VAP模板 名称:net,net2

业务VLAN:VLAN 20

转发模式:直接转发

VAP模板 名称:net,net2

引用模板:SSID模板 net

vap-profile name net

forward-mode tunnel 

service-vlan vlan-id 20 

ssid-profile net

security-profile snet

业务VLAN:VLAN 30

转发模式:直接转发

VAP模板 名称:net,net2

引用模板:SSID模板 net2

vap-profile name net2
  forward-mode tunnel
  service-vlan vlan-id 30
  ssid-profile net
  security-profile snet
q

ap-id 0  type-id 69 ap-mac 00E0-FC2F-14F0
ap-name wifi-1
ap-group apg

q
ap-id 1 type-id 69 ap-mac 00E0-FC7A-5940
ap-name wifi-2
ap-group apg

ap-id 2 type-id 69 ap-mac 00E0-FCAA-62B0
ap-name wifi-3
ap-group apg

q
ap-group name apg
vap-profile net wlan 1 radio 0
vap-profile net wlan 1 radio 1

vap-profile net2 wlan 2 radio 0
vap-profile net2 wlan 2 radio 1

七.验证

AC

display ap all
display ip interface brief 

图例:

AC3y003245.png

a